Projects
View on GitHub
ireader/media-server
ireader/media-server has 3,529 GitHub stars and 1,163 forks. GitHot measured 0 stars in 24 hours. Last checked 2026-11-07 17:38 UTC. Last push 2026-10-10.
RTSP/RTP/RTMP/FLV/HLS/MPEG-TS/MPEG-PS/MPEG-DASH/MP4/fMP4/MKV/WebM
Measured star growth
- in 24h
- 0
- in 7 days
- Collecting history
- in 15 days
- Collecting history
- in 1 month
- Collecting history
Net star changes over overlapping periods, not daily totals. Missing measurements are left blank. Stars measure attention, not software quality.
README.md
Original- Build status:
- Build Dependence: https://github.com/ireader/sdk
libflv
- FLV video codec: H.264/H.265/H.266/AV1/VP8/VP9/VP10
- FLV audio codec: AAC/MP3/G.711/Opus
- FLV file read/write
- H.264/H.265/H.266/AV1 bitstream filter: annex-b <-> mp4 stream
- AAC bitstream filter: ADTS <-> ASC
librtmp
- rtmp-client: RTMP publish/play
- rtmp-server: RTMP Server live/vod streaming
libmpeg
- ITU-T H.222.0 PS/TS read/write
- ps/ts codec: H.264/H.265/H.266/AAC/MP3/G.711/Opus
librtp
- RFC3550 RTP/RTCP
- RTP with H.264/H.265/H.266/MPEG-2/MPEG-4/VP8/VP9/AV1
- RTP with G.711/G.726/G.729/MP3/AAC/Opus
- RTP with MPEG-2 PS/TS
- RTP Header Extension
- RTCP PSFB/RTPFB/XR
librtsp
- RFC2326 RTSP
- RFC4566 SDP
- SDP fmtp: H.264/H.265/H.266/AAC/Opus/G.711
libhls
- HLS M3U8: generate m3u8 file
- HLS Media: TS segmenter
- HLS fmp4 segmenter
- HLS Master/Playlist m3u8 parser
libdash
- ISO/IEC 23009-1 MPEG-DASH static(vod)
- ISO/IEC 23009-1 MPEG-DASH dynamic(live)
- DASH MPD v3/v4 parser
libmov
- ISO/IEC 14496-12 MP4 File reader/writer
- MP4 faststart(moov box before mdat)
- fMP4(Fragment MP4) writer
- MP4 with H.264/H.265/H.266/AV1/VP8/VP9/JPEG/PNG
- MP4 with AAC/Opus/MP3/G.711
libmkv
- MKV/WebM file read/write
- MKV/WebM live streaming
libsip
- sip user-agent (UAC/UAS)
- sip with ICE
libhttp(https://github.com/ireader/sdk)
- HTTP Server(base AIO)
- HTTP Client
- HTTP Cookie
Make
- make clean && make
- make RELEASE=1 (make release library, default debug)
- make PLATFORM=arm-hisiv100nptl-linux (cross compile)
编译说明
友情链接
| ZLMediaKit | 基于C++11的高性能运营级流媒体服务框架 |
| MediaInsight360 | 流媒体格式在线解析 |
Explore related projects
freeCodeCamp/freeCodeCamp
freeCodeCamp.org's open-source codebase and curriculum. Learn math, programming, and computer science for free.
458,721 starsdonnemartin/system-design-primer
Learn how to design large-scale systems. Prep for the system design interview. Includes Anki flashcards.
377,262 starsreact/react
The library for web and native user interfaces.
252,365 starsvuejs/vue
This is the repo for Vue 2. For Vue 3, go to https://github.com/vuejs/core
212,629 stars