go-acme/lego has 10,009 GitHub stars and 1,183 forks. GitHot measured +1 stars in 24 hours and +22 in 7 days. Last checked 2026-11-06 16:38 UTC. Last push 2026-11-02.
Let's Encrypt/ACME client and library written in Go
What you can do
- Support RFC 8737: TLS Application‑Layer Protocol Negotiation (ALPN) Challenge Extension
- Support RFC 8738: certificates for IP addresses
- Support RFC 9773: Renewal Information (ARI) Extension
- Support draft-ietf-acme-profiles-00: Profiles Extension
Measured star growth
- in 24h
- +1
- in 7 days
- +22
- in 15 days
- Update delayed
- in 1 month
- Update delayed
Net star changes over overlapping periods, not daily totals. Missing measurements are left blank. Stars measure attention, not software quality.
README.md
OriginalAutomatic Certificates and HTTPS for everyone.
Lego
ACME client and library for Let's Encrypt and other ACME CAs written in Go.
lego is an independent, free, and open-source project, if you value it, consider supporting it! ❤️
Everybody thinks that the others will donate, but in the end, nobody does.
So if you think that lego is worth it, please consider donating.
Features
- ACME v2 RFC 8555
- Support RFC 8737: TLS Application‑Layer Protocol Negotiation (ALPN) Challenge Extension
- Support RFC 8738: certificates for IP addresses
- Support RFC 9773: Renewal Information (ARI) Extension
- Support draft-ietf-acme-profiles-00: Profiles Extension
- Support draft-ietf-acme-dns-persist-01: Challenge for Persistent DNS TXT Record Validation
- Comes with more than 200 DNS providers
- Register with CA
- Obtain certificates, both from scratch or with an existing CSR
- Renew certificates
- Revoke certificates
- Robust implementation of ACME challenges:
- HTTP (http-01)
- DNS (dns-01)
- TLS (tls-alpn-01)
- SAN certificate support
- CNAME support by default
- Custom challenge solvers
- Certificate bundling
- OCSP helper function
Installation
How to install.
Usage
Documentation
Documentation is hosted live at https://go-acme.github.io/lego/.
DNS providers
Detailed documentation is available here.
If your DNS provider is not supported, please open an issue.
If your DNS provider is not supported, please open an issue.
Explore related projects
trimstray/the-book-of-secret-knowledge
A collection of inspiring lists, manuals, cheatsheets, blogs, hacks, one-liners, cli/web tools and more.
256,511 starsHack-with-Github/Awesome-Hacking
A collection of various awesome lists for hackers, pentesters and security researchers
124,831 starsswisskyrepo/PayloadsAllTheThings
A list of useful payloads and bypass for Web Application Security and Pentest/CTF
82,444 starscaddyserver/caddy
Fast and extensible multi-platform HTTP/1-2-3 web server with automatic HTTPS
78,857 stars