Skip to content
프로젝트

go-acme/lego has 10,015 GitHub stars and 1,183 forks. GitHot measured +1 stars in 24 hours and +19 in 7 days. Last checked 2026-11-09 13:23 UTC. Last push 2026-11-02.

이 수치를 측정하는 방법

Go로 작성된 Let's Encrypt/ACME 클라이언트 및 라이브러리

What you can do

  • Support RFC 8737: TLS Application‑Layer Protocol Negotiation (ALPN) Challenge Extension
  • Support RFC 8738: certificates for IP addresses
  • Support RFC 9773: Renewal Information (ARI) Extension
  • Support draft-ietf-acme-profiles-00: Profiles Extension

측정된 스타 증가

in 24h
+1
in 7 days
+19
in 15 days
업데이트 지연
in 1 month
업데이트 지연

서로 겹치는 기간의 순증가량이며 일별 합계가 아닙니다. 측정값이 없으면 비워 둡니다. 스타는 관심도를 나타내며 품질을 보장하지 않습니다.

README.md

Original
lego logo

Automatic Certificates and HTTPS for everyone.

Lego

ACME client and library for Let's Encrypt and other ACME CAs written in Go.

Go Reference Build Status Docker Pulls

lego is an independent, free, and open-source project, if you value it, consider supporting it! ❤️

Everybody thinks that the others will donate, but in the end, nobody does.

So if you think that lego is worth it, please consider donating.

Features

  • ACME v2 RFC 8555
  • Comes with more than 200 DNS providers
  • Register with CA
  • Obtain certificates, both from scratch or with an existing CSR
  • Renew certificates
  • Revoke certificates
  • Robust implementation of ACME challenges:
    • HTTP (http-01)
    • DNS (dns-01)
    • TLS (tls-alpn-01)
  • SAN certificate support
  • CNAME support by default
  • Custom challenge solvers
  • Certificate bundling
  • OCSP helper function

Installation

How to install.

Usage

Documentation

Documentation is hosted live at https://go-acme.github.io/lego/.

DNS providers

Detailed documentation is available here.

If your DNS provider is not supported, please open an issue.

1cloud.ru 35.com/三五互联 51DNS Abion
Active24 Akamai EdgeDNS Alibaba Cloud DNS AlibabaCloud ESA
all-inkl Alwaysdata Amazon Lightsail Amazon Route 53
Anexia CloudDNS ANS SafeDNS ArtFiles ArvanCloud
Aurora DNS Autodns Axelname Azion
Azure DNS Baidu Cloud Beget.com Binary Lane
Bindman Bluecat Bluecat v2 BookMyName
Bunny Checkdomain Civo Cloud.ru
CloudDNS Cloudflare ClouDNS CloudPress
Com Laude Connbyte ConoHa v2 ConoHa v3
Constellix Core-Networks CPanel/WHM Curanet
Czechia DanDomain DDnss (DynDNS Service) Derak Cloud
deSEC.io Designate DNSaaS for Openstack Digital Ocean Dinahosting
DirectAdmin DNS Made Easy DNS Update (RFC2136) dns.la
DNS.services DNScale DNSExit dnsHome.de
DNSimple DNSMint Domain Offensive (do.de) Domeneshop
DreamHost Duck DNS Dyn Dynadot
DynDnsFree.de Dynu EasyDNS EdgeCenter
Efficient IP Epik EuroDNS EUserv
Excedo Exoscale External program F5 XC
FENO Fornex freemyip.com FusionLayer NameSurfer
G-Core Gandi Gandi Live DNS (v5) Gehirn
Gigahost.no Glesys Gname Go Daddy (DEPRECATED)
Go Daddy (v3) Google Cloud Gravity Hetzner
Hosting.de Hosting.nl Hostinger Hosttech
HostUp HTTP request http.net Huawei Cloud
Hurricane Electric DNS HyperOne IBM Cloud (SoftLayer) IIJ DNS Platform Service
Infoblox Infomaniak Internet.bs INWX
Ionos Ionos Cloud IPv64 ISPConfig 3
ISPConfig 3 - Dynamic DNS (DDNS) Module JD Cloud Joker Joohoi's ACME-DNS
Katapult KeyHelp Leaseweb Liara
Lima-City Linode (v4) Liquid Web Loopia
LuaDNS Mail-in-a-Box ManageEngine CloudDNS Manual
Metaname Metaregistrar mijn.host Mittwald
myaddr.{tools,dev,io} MyDNS.jp Myra MythicBeasts
Name.com Namecheap Namesilo NearlyFreeSpeech.NET
NederHost Neodigit Netcup (Legacy API) Netcup v1
Netlify Netnod NexDNS Ngenix
Nicmanager NIFCloud Njalla Nodion
NordName NS1 Octenium omg.lol
Online.net Open Telekom Cloud Openprovider OpusDNS
Oracle Cloud OVH plesk.com PointDNS/PointHQ
Porkbun Poweradmin PowerDNS PrimeDNS
Rackspace Rage4 Rain Yun/雨云 RcodeZero
reg.ru Regfish RimuHosting RU CENTER
Sakura Cloud Scaleway ScanNet Selectel
Selectel v2 SelfHost.(de|eu) SelfHost.(de|eu) (DEPRECATED) Servercow
Shellrent Simply.com Sonic Spaceship
Stackpath (Deprecated) Syse Technitium Tele3
Tencent Cloud DNS Tencent EdgeOne Timeweb Cloud TodayNIC/时代互联
TransIP UCloud Ultradns United-Domains
Variomedia Veesp VegaDNS Vercel
Versio.[nl|eu|uk] VinylDNS Virtualname VK Cloud
Volcano Engine/火山引擎 Vscale Vultr Wannafind
Webglobe webnames.ca webnames.ru Websupport
WEDOS West.cn/西部数码 Xinnet Yandex 360
Yandex Cloud Yandex PDD Zilore Zone.ee
ZoneEdit Zonomi

If your DNS provider is not supported, please open an issue.

관련 프로젝트 살펴보기